Exoscale status

Our DNS partner is currently experiencing issues.

resolved

DNS systems working as expected.

investigating

We are seeing issues with some dns queries.