Exoscale status

Network: Increased internet latency

resolved

All systems operational

monitoring

Issue has been mitigated, we're monitoring the situation

identified

The issue is related to one of our internet transit provider. Traffic is being re-routed to alternate paths

investigating

We're investigating increased internet latency at CH-DK2 and DE-FRA-1