Exoscale status

Increased network latency in MUC1

resolved

The situation is now stable and everything is back to normal in MUC1.

monitoring

Situation is now under control. We are monitoring the situation.

investigating

Increased network latency in MUC1. We are currently investigating the situation.