Exoscale status
Feb 01, 2021
CH-GVA-2: Increased latency
Global Overview
All Incidents
10:44 CET
resolved
All systems operational
10:22 CET
investigating
We're investigating increased latency for SOS CH-GVA-2