Exoscale status

GVA-2: increased network latency

resolved

Duplicate incident

investigating

The issue is related with one of our internet transit provider, we are implementing a traffic re-routing

investigating

We're investigating increased network latency in GVA2