Exoscale status

DE-MUC-1: Increase internet network latency

resolved

All systems operational

monitoring

The issue has been mitigated. We're monitoring the situation

identified

Issue has been identified, we're working on the mitigation

investigating

We're investigating increased internet latency in DE-MUC-1