Exoscale status

DNS issue with name servers

resolved

Our DNS partner is currently experiencing an issue on several of their datacenters

identified

Our DNS partner is currently experiencing an issue on several of their datacenters.