Exoscale status

DNS: Increase of error rate

resolved

All systems operational

investigating

Mitigation are still in progress, significant improvements can already been noticed

investigating

Our DNS partner is currently experiencing degraded performance with their name servers in some regions. They are working on mitigating the issue.