Exoscale status

Degraded performance for our DNS offering

resolved

This incident has been resolved.

monitoring

Traffic levels are back to normal and our DNS partner is monitoring the situaton

investigating

Name server resolution is curently being investigated by our DNS partner.

investigating

Currently investigating the issue