Exoscale status

DNS: Increase of error rate

resolved

All systems back to nominal

monitoring

DNS resolution has been restored. We are monitoring the situation.

investigating

Our DNS partner is currently experiencing degraded performance with their name servers in some regions. They are working on mitigating the issue.