Exoscale status

SOS MUC1 increased latency

resolved

The situation is now back to normal.

monitoring

The issue has been identified and fixed. We are now monitoring the situation.

investigating

There is currently an increase of latency on SOS MUC1 we are investigating the issue.