Exoscale status

DNS resolution issues

resolved

A fix has been roll out and the situation is now stable.

identified

Our provider is still working to fix the situation. We are waiting for more information in the next update.

identified

Our DNS provider is experiencing issues. It should be solve quickly we are monitoring the situation.