Exoscale status

Partial network outage (in zone MUC1)

resolved

All systems back to nominal

monitoring

Traffic is getting back to normal.

monitoring

We are currently experiencing a very high volume of traffic.

monitoring

Network latencies