Exoscale status

DE-MUC-1: Increased internet network latency

resolved

All systems operational

investigating

The issue has been mitigated. Monitoring the situation

investigating

We're investigating an increased internet network latency in DE-MUC-1