Exoscale status

DNS record listing issue

resolved

System back to nominal

monitoring

Fix deployed. Issue should now be fixed.

identified

Underlying (sporadic) issue identified. A fix is being prepared.

identified

We have identified an issue incapacitating the management of DNS records and zones hosted on our platform.