Exoscale status

We are currently experiencing degraded performance on private network API calls

resolved

API calls for private network managment are back to normal behavior.

investigating

Adding or removing Nics to private networks might be impacted.