Exoscale status

Degraded performance for our DNS offering

resolved

The DNS performance issue is now resolved.

monitoring

Our partner has mitigated the issue and we are now monitoring the situation.

identified

Name server resolution is curently being investigated by our DNS partner.

investigating

Currently investigating the issue