Exoscale status

USA Routing Degradation

resolved

The problem has been indetified and solved by our upstream provider.
All systems are now back to nominal.

monitoring

One of our upstream providers is experiencing some issue between London and New York so traffic to destination in the US might be impacted.
Investigation with our supplier is in progress. To mitigate the issue that traffic has been re-routed for the time being.