Exoscale status

Partial network outage (in zone MUC1)

resolved

All systems back to nominal

monitoring

Traffic is getting back to normal.

investigating

We're investigating an increased internet network latency in DE-MUC-1