Exoscale status
Dec 03, 2020
Network instability
Global Overview
All Incidents
00:40 CET
resolved
All systems back to nominal
00:28 CET
investigating
Intermittent network disruption with upstream providers