Exoscale status

SOS CH-DK-2 increased latency

resolved

All systems operational

identified

We're working on mitigating the issue

investigating

We're investigating increased latency on SOS CH-DK-2