Exoscale status

DE-MUC-1: Increased internet network latency

resolved

Situation has been resolved. All systems green.

monitoring

The issue has been mitigated, we're monitoring the situation

investigating

We're investigating an increased internet latency in DE-MUC-1