Exoscale status

Portal is down

resolved

All systems operational

monitoring

Portal is back up. We're monitoring the situation

investigating

We're investigating an issue with portal.exoscale.com