Exoscale status

CH-DK-2: Internet increased latency and packet loss

resolved

All systems operational

monitoring

Issue has been mitigated, we're monitoring the situation

identified

Issue has been identified and mitigation is in progress

investigating

We are investigating Internet increased latency and packet loss issue