Exoscale status

DNS service unreachable from some locations

resolved

No further issues have been observed since late yesterday.

monitoring

DNS records are resolvable again. We are monitoring the situation.

identified

Hosted DNS zones are currently not resolving records for clients in some locations. Note that this doesn't affect general DNS lookups.