Exoscale status

Compute Load Balancer: connectivity issue

resolved

All systems operational

monitoring

Service is recovering, monitoring the situation

investigating

We're investigating connectivity issue with load balancers