Exoscale
Platform Status

[Network] Increased internet network latencies and packet loss

Degraded performance DE-FRA-1 API Block Storage Compute Concrete AI Dedicated Inference Key Management Service KMS Managed Database service DBaaS Managed Kubernetes SKS Managed Private Networks Network Internet Transit Connectivity Network Load Balancer NLB Object Storage SOS
2026-07-24 00:54 CEST · 2 hours

Updates

Investigating

Network latency issue is now resolved.

July 24, 2026 · 02:54 CEST
Investigating

Network latency issue is now resolved.

July 24, 2026 · 01:41 CEST
Issue

We are investigating Increased internet network latencies and packet loss. We’ll post an update as soon as we have more information.

July 24, 2026 · 00:54 CEST

← Back