Exoscale
Platform Status

Datacenter power redundancy reduction

Degraded performance CH-DK-2 API Block Storage Compute Managed Database service DBaaS Managed Kubernetes SKS Managed Private Networks Network Internet Transit Connectivity Network Load Balancer NLB Object Storage SOS
2026-03-16 15:53 CET · 5 hours, 8 minutes

Updates

Monitoring

The fire brigade managed to extinguish the active fire in the impacted UPS room. They also managed to prevent propagation of the fire to adjacent rooms. The facility is currently evacuated while the fire brigade assesses safety. Once facility staff have access, they will start the remediation process.

The situation is stable. All our services remain available while the power redundancy of the datacenter facility remains reduced to N.

We will provide an update as soon as we get more information from our data center facility provider.

March 16, 2026 · 17:12 CET
Monitoring

The dacenter facility experienced a fire in one or more UPS rooms. As a consequence the datacenter has been evacuated and the fire brigade dispatched to suppress the fire. The latest updates we have received suggest that the fire has been contained. In order to access the area the fire brigade requested to deenergize some circuits, reducing the datacenter facility power feeds to N.

Our services are not impacted at this stage and remain available. We are in close contact with our datacenter facility provider and monitoring the situation.

March 16, 2026 · 15:53 CET

← Back