Exoscale
Platform Status

DNS Issue

Degraded performance Global DNS
2026-02-10 18:09 CET · 3 hours, 21 minutes

Updates

Resolved

DNS Provider confirms the issue is resolved.

Over last hour we have not noticed any failures pointing to DNS.
Situation is considered to be back to nominal and issue as resolved.

February 10, 2026 · 21:28 CET
Monitoring

Nameservers have recovered and all internal healthchecks are green.

We’ll keep monitoring the situation.

February 10, 2026 · 20:26 CET
Update

Mitigation has been successfully applied.

Nameservers are expected to recover soon.

February 10, 2026 · 20:22 CET
Update

Second mitigation is in progress of being applied on the DNS provider side.

Services are expected to come back shortly.

February 10, 2026 · 19:52 CET
Update

Mitigation applied by our DNS provider has failed.
Alternative solutions are being explored.

We’re continuing to monitor the situation.

February 10, 2026 · 19:09 CET
Update

Root cause has been identified by the DNS provider and a proper mitigation is being deployed.

February 10, 2026 · 18:52 CET
Update

DNS Provider is starting to slowly restore services.

February 10, 2026 · 18:32 CET
Issue

Our DNS vendor is experiencing performance issues.

February 10, 2026 · 18:09 CET

← Back