Exoscale
Subscribe
to updates
Exoscale
Platform Status
[DNS] Intermittent resolution issues
Degraded performance
Global
DNS
2025-10-29 23:02 CET
· 19 minutes
Updates
Resolved
We are closing this incident
October 29, 2025 · 23:21 CET
Investigating
We are closing this incident.
October 29, 2025 · 23:20 CET
Investigating
We are closing this incident.
October 29, 2025 · 23:02 CET
← Back