Exoscale status

Increased internet latency at CH-GVA-2

resolved

Issue is now resolved. It was related to a transit issue with one of our upstream providers

investigating

We're investigating Increased internet latency at CH-GVA-2