Exoscale
Platform Status

[DNS] Increased Error Rates and Latencies

Partial outage Global DNS
2025-07-29 02:36 CEST · 39 minutes

Updates

Resolved

exoscale.com DNS zone is now in nominal state.

July 29, 2025 · 03:15 CEST
Investigating

The problem has been identified, we are working on a fix at the moment.

July 29, 2025 · 02:45 CEST
Issue

We are investigating an Increased resolution error rates and latencies on the DNS service. We’ll post an update as soon as we have more information.

July 29, 2025 · 02:36 CEST

← Back