Exoscale
Platform Status

[DNS] Increased Error Rates and Latencies

Partial outage Global DNS
2025-07-28 23:44 CEST · 38 minutes

Updates

Resolved

exoscale.com DNS zone is now in nominal state.

July 29, 2025 · 00:22 CEST
Investigating

exoscale.com is the only zone concerned.

July 29, 2025 · 00:06 CEST
Investigating

Only queries with DNSSEC validation are impacted.

July 28, 2025 · 23:53 CEST
Issue

We are investigating an Increased resolution error rates and latencies on the DNS service. We’ll post an update as soon as we have more information.

July 28, 2025 · 23:44 CEST

← Back