[Network] Increased internet network latencies and packet loss
Degraded performance
CH-DK-2
Network Internet Transit Connectivity
2025-07-18 10:18 CEST
· 5 hours, 8 minutes
Updates
Resolved
July 18, 2025 · 15:26 CEST
Mitigation is now effective, we have replaced a defective hardware component.
Incident has been resolved
Issue
July 18, 2025 · 10:18 CEST
We are investigating Increased internet network latencies and packet loss. We’ll post an update as soon as we have more information.
← Back