Exoscale
Platform Status

DNS issue

Informational Global DNS
2025-05-07 19:21 CEST · 2 hours, 20 minutes

Updates

Resolved

Issue has been resolved.

May 7, 2025 · 21:42 CEST
Monitoring

Systems are back to nominal state.
We’re continuing to monitor the situation.

May 7, 2025 · 21:29 CEST
Investigating

The provider is still investigating the issue.

May 7, 2025 · 20:00 CEST
Issue

Our DNS vendor is experiencing performance issues.

May 7, 2025 · 19:21 CEST

← Back