Exoscale status

High network latency

resolved

All systems operational

monitoring

Issue has been fixed and services are back to normal.

investigating

We're investigating high network latency in all zones. We're investigating. The portal is highly impacted, please use the cli (https://github.com/exoscale/cli)