Exoscale status

Compute issues

resolved

Incident closed

monitoring

Performance is back to normal

identified

We have identified the failure and are applying a fix

investigating

Following a network failure with a partner, we observe degraded performance in our compute offering