Exoscale status

Our DNS provider is currently experiencing some issues. Resulting to some DNS issues to reach Exoscale.

resolved

The situation is now back to normal.

monitoring

Our DNS provider is currently experiencing some issues. Resulting to some DNS issues to reach Exoscale.